Bernu Dwi Andika

Icon

explain what this blog is about.

ospfd.conf

! -*- ospf -*-
!
! OSPFd sample configuration file
!
!
hostname ospfd@routerlt2
password zebra
!enable password please-set-at-here
!
interface fxp0
ip ospf cost 10
ip ospf dead-interval 90
!
interface sk0
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 2
!
interface sk1
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 3
!
interface sk2
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 4
!
router ospf
ospf router-id 167.205.19.xxx
network 167.205.0.0/16 area 0.0.0.0
!
line vty
!log stdout

Advertisements

Filed under: Router

Konfigurasi zebra.conf

! -*- zebra -*-
!
! $Id: zebra.conf.sample,v 1.1.1.1 2002/12/13 20:15:30 paul Exp $
!
hostname zebra@routerlt2
password zebra
enable password zebra
!
interface sk0
ipv6 nd suppress-ra
!
interface sk1
ipv6 nd suppress-ra
!
interface sk2
ipv6 nd suppress-ra
!
interface fxp0
ipv6 nd suppress-ra
!
access-list 1 permit 167.205.30.xxx
access-list 1 deny any
!
line vty
!

Filed under: Router

Konfigurasi rc.conf (quagga)

# — sysinstall generated deltas — # Tue Apr 1 00:16:45 2008
# Created: Tue Apr 1 00:16:45 2008
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
#
defaultrouter=”NO”
hostname=”routerlt2.ti.itb.ac.id”
gateway_enable=”YES”

## Other
ipv6_enable=”YES”
ntpdate_enable=”YES”
ntpdate_flags=”pool.ntp.org”
sshd_enable=”YES”
usbd_enable=”NO”

## Interface
ifconfig_fxp0=”inet 167.205.30.xxx netmask 255.255.255.240″
#ipv6_network_interfaces=”fxp0″
#ipv6_ifconfig_fxp0=”2001:d30:3:182::10 prefixlen 64″
ifconfig_sk0=”inet 167.205.19.xxx netmask 255.255.255.240″
ifconfig_sk1=”inet 167.205.19.xxx netmask 255.255.255.248″
ifconfig_sk2=”inet 167.205.19.xxx netmask 255.255.255.224″

## Quagga
quagga_enable=”YES”
quagga_daemons=”zebra ospfd”
watchquagga_enable=”YES”

Filed under: Router

Konfigurasi Awal FreeBSD

0. melihat status ethenet komputer :
# ifconfig -a

1. buat IP di mesin
# ifconfig nve0 inet 167.205.xxx.xxx netmask 255.255.255.224 up

2. mengatur gateway
# route add default 167.205.xxx.xxx

3. mengatur rc.conf
# cd /etc
# vi rc.conf
, lakukan konfigurasi awal :

usbd_enable=”YES”
ifconfig_nve0=”inet 167.205.xxx.xxx netmask 255.255.255.192″
hostname=”bernu.xxx.com”
sshd_enable=”YES”

* sshd_enable berfungsi awal mesin dapat kita lakukan ssh

4. mengatur resolv.conf
# cd /etc
# vi resolv.conf
, lakukan konfigurasi awal :

domain xxx.com
nameserver 167.205.xxx.xxx

5. mengatur make.conf
# cd /etc
# vi make.conf
, lakukan konfigurasi awal :

#CFLAGS= -O -pipe
#COPTFLAGS= -O -pipe
#NOPROFILE= true
NO_PF=true
FETCH_ENV= ftp_proxy=http://cache.xxx.com:8080/
FETCH_ENV= http_proxy=http://cache.xxx.com:8080/
#FETCH_ENV= HTTP_PROXY=http://167.205.xxx.xxx:8888/
MASTER_SITE_OVERRIDE=ftp://ftp.itb.ac.id/pub/FreeBSD/ports/distfiles/${DIST_SUBDIR}/
#MASTER_SITE_OVERRIDE=ftp://ftp.freebsd.org/pub/FreeBSD/ports/distfiles/${DIST_SUBDIR}/

BATCH=YES
WITHOUT_X11=YES
SKIP_DNS_CHECK=YES
CRYPT_DES=0
PORT_REPLACES_BASE_BIND8=YES
PORT_REPLACES_BASE_BIND9=YES
WITHOUT_ALT_CONFIG_PREFIX=YES
WITH_OPENSSL_PORT=YES

#*REMOVE* OPENSSL_OVERWRITE_BASE=NO

# added by use.perl 2005-11-29 16:28:51
PERL_VER=5.8.7
PERL_VERSION=5.8.7

6. restart konfigurasi di /etc/rc.conf
# sh /etc/rc

7. memeriksa koneksi jaringan
# ping www.itb.ac.id

Filed under: FreeBSD