Bernu Dwi Andika

Icon

explain what this blog is about.

Dynamic Routing with Quagga

  1. Install ‘net/quagga’ from ports:
    # cd /usr/ports/net/quagga
    # make
    # make install
    
  2. Copy the sample configuration files into place
    # cd /usr/local/etc/quagga
    # cp /usr/local/share/examples/quagga/zebra.conf.sample zebra.conf
    # cp /usr/local/share/examples/quagga/ospfd.conf.sample ospfd.conf
    
  3. Have a look at these files; they are very simple. “zebra” is the overall manager of the IP forwarding table; “ospfd” is the daemon which speaks the OSPF protocol. Read the rest of this entry »
Advertisements

Filed under: FreeBSD, Router

FreeBSD stable upgrade

We are going to upgrade our FreeBSD system with the CVSup tutorial. The FreeBSD team unlike Linux develops the Kernel and World. They are separate parts but linked together. Good practice will tell you not to upgrade just the kernel but the entire system.

Let check to see what we are running:

host# uname -a

We are going to assume that you have the ports system installed. Ports is a system that was developed to make it easy to install all types of software. Think of it like the Windows Add/Remove idea with a twist. You can check by going to /usr and looking for a ports folder. If you don’t have anything in that folder you can download it here:

host# cd /usr
host# fetch ftp://ftp.freebsd.org/pub/FreeBSD/ports/ports/ports.tar.gz
host# tar -xzf ports.tar.gz

Now we will install cvsup.

host# /usr/ports/net/cvsup make && make install

What we need to do is get a configuration file and make the necessary changes before upgrading the system. We will get the example file and move it to the root level. Read the rest of this entry »

Filed under: FreeBSD, Maintenance

ospfd.conf

! -*- ospf -*-
!
! OSPFd sample configuration file
!
!
hostname ospfd@routerlt2
password zebra
!enable password please-set-at-here
!
interface fxp0
ip ospf cost 10
ip ospf dead-interval 90
!
interface sk0
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 2
!
interface sk1
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 3
!
interface sk2
ip ospf cost 10
ip ospf dead-interval 90
ip ospf priority 4
!
router ospf
ospf router-id 167.205.19.xxx
network 167.205.0.0/16 area 0.0.0.0
!
line vty
!log stdout

Filed under: Router

Konfigurasi zebra.conf

! -*- zebra -*-
!
! $Id: zebra.conf.sample,v 1.1.1.1 2002/12/13 20:15:30 paul Exp $
!
hostname zebra@routerlt2
password zebra
enable password zebra
!
interface sk0
ipv6 nd suppress-ra
!
interface sk1
ipv6 nd suppress-ra
!
interface sk2
ipv6 nd suppress-ra
!
interface fxp0
ipv6 nd suppress-ra
!
access-list 1 permit 167.205.30.xxx
access-list 1 deny any
!
line vty
!

Filed under: Router

Konfigurasi rc.conf (quagga)

# — sysinstall generated deltas — # Tue Apr 1 00:16:45 2008
# Created: Tue Apr 1 00:16:45 2008
# Enable network daemons for user convenience.
# Please make all changes to this file, not to /etc/defaults/rc.conf.
# This file now contains just the overrides from /etc/defaults/rc.conf.
#
defaultrouter=”NO”
hostname=”routerlt2.ti.itb.ac.id”
gateway_enable=”YES”

## Other
ipv6_enable=”YES”
ntpdate_enable=”YES”
ntpdate_flags=”pool.ntp.org”
sshd_enable=”YES”
usbd_enable=”NO”

## Interface
ifconfig_fxp0=”inet 167.205.30.xxx netmask 255.255.255.240″
#ipv6_network_interfaces=”fxp0″
#ipv6_ifconfig_fxp0=”2001:d30:3:182::10 prefixlen 64″
ifconfig_sk0=”inet 167.205.19.xxx netmask 255.255.255.240″
ifconfig_sk1=”inet 167.205.19.xxx netmask 255.255.255.248″
ifconfig_sk2=”inet 167.205.19.xxx netmask 255.255.255.224″

## Quagga
quagga_enable=”YES”
quagga_daemons=”zebra ospfd”
watchquagga_enable=”YES”

Filed under: Router